You are here: start » system_requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
system_requirements [2017/11/01 15:22]
127.0.0.1 external edit
system_requirements [2018/09/19 17:00]
Christoph M. Becker [Your Personal Computer] IE is water under the bridges
Line 5: Line 5:
 ===== Web Server ===== ===== Web Server =====
  
-CMSimple_XH requires PHP 5.3 or higher (successfully tested up to 7.1). At least PHP 5.6 is recommended,​ though; if the server is running an older PHP version, you can probably switch to PHP 5.6 or higher in the wespace'​s control panel. The PHP extensions "date", "pcre""​session" and "xml" have to be installed, what'​s ​normally ​the case everywhere.+CMSimple_XH ​1.7 requires PHP 5.3 or higher (successfully tested up to 7.2.0). At least PHP 5.6 is recommended,​ though; if the server is running an older PHP version, you can probably switch to PHP 5.6 or higher in the wespace'​s control panel. The PHP extensions "json", "mbstring" ​and "​session"​ have to be available, what'​s ​usually ​the case everywhere.
  
 No database is required, as all data are stored in flat files. ​ No database is required, as all data are stored in flat files. ​
Line 15: Line 15:
 You need an [[FTP]] client to upload and download files and folders to the server and to assign [[filesystem_permissions|reading and writing permissions]]. You need an [[FTP]] client to upload and download files and folders to the server and to assign [[filesystem_permissions|reading and writing permissions]].
  
-And of course you need a browser to administrate your site. The newest version of Firefox, ​Internet Explorer, Chrome, Safari or Opera are recommended. It's mandatory to have [[javascript]] and Cookies enabled. Because popup and ad blockers might suppress important dialogs and other functionality,​ you have to disable them when necessary or you have to add respective exceptions to the popup or ad blocker.+And of course you need a browser to administrate your site. The newest version of Firefox, ​Edge, Chrome, Safari or Opera are recommended. It's mandatory to have [[javascript]] and Cookies enabled. Because popup and ad blockers might suppress important dialogs and other functionality,​ you have to disable them when necessary or you have to add respective exceptions to the popup or ad blocker.
  
 ===== Extensions ===== ===== Extensions =====
  
 Some [[extensions]] might have more demanding requirements,​ for example some plugins require PHP 5 to function properly. This should be mentioned in the dokumentation of the respective extensions. Some [[extensions]] might have more demanding requirements,​ for example some plugins require PHP 5 to function properly. This should be mentioned in the dokumentation of the respective extensions.
 
You are here: start » system_requirements
Except where otherwise noted, content on this wiki is licensed under the following license: GNU Free Documentation License 1.3
Valid XHTML 1.0 Valid CSS Driven by DokuWiki