Sie befinden sich hier: start » de » system_requirements

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

de:system_requirements [2017/08/31 22:02]
Hartmut Keil [Web-Server]
de:system_requirements [2018/10/26 15:33]
Zeile 1: Zeile 1:
-====== Systemanforderungen ====== 
  
-CMSimple_XH wurde so entwickelt, dass es auf nahezu jedem Webserver ausgeführt werden kann. Für die Installation und den Betrieb gelten die in den folgenden Abschnitten angegebenen server- und clientseitigen Voraussetzungen. ​ 
- 
-===== Web-Server ===== 
- 
-CMSimple_XH benötigt PHP 5.3 oder höher (erfolgreich getestet bis PHP 7.1.2). Allerdings wird zumindest PHP 5.6 empfohlen. 
-Die PHP-Erweiterung "​session"​ muss auf dem Server vorhanden sein, was normalerweise auch der Fall ist. 
-Weiterhin wird die PHP Erweiterung "​mbstring " für die Utf8 Funktionalität benötigt, die laut PHP Doc zwar nicht zum PHP Standard gehört, allerdings auf den Servern in der Regel zur Verfügung steht. 
-Eine recht gute Übersicht ob alle wichtigen bzw. optionalen Anforderungen für CMSimple_XH 1.7 erfüllt sind, können auch im Adminbereich unter "​Einstellungen"​ =>  "​System-Info"​ eingesehen werden. 
- 
-Es wird keine Datenbank benötigt, da alle Daten in einfachen Dateien gespeichert werden. 
- 
-Ein Apache HTTP-Server wird empfohlen, aber CMSimple_XH sollte auch auf auf anderen Servern laufen (erfolgreich getestet mit IIS und NGINX). 
- 
-===== Ihr PC ===== 
- 
-Sie benötigen einen [[FTP]]-Client um Dateien und Verzeichnisse auf den Server hoch bzw. von dort wieder herunter zu laden, und um [[filesystem_permissions|Dateiberechtigungen]] zu ändern. 
- 
-Und selbstverständlich brauchen Sie einen Browser um Ihre Seite administrieren zu können. Wir empfehlen die neuste Version von Firefox, Internet Explorer, Chrome, Safari oder Opera. Es ist zwingend notwendig dass [[javascript]] und Cookies aktiviert sind. Da Popup- und Werbeblocker unter Umständen wichtige Dialoge und andere Funktionen unterdrücken können, sind diese bei Bedarf zu deaktivieren oder es ist eine entsprechende Ausnahmeregel im Popup- bzw. Werbeblocker hinzuzufügen. 
- 
-===== Erweiterungen ===== 
- 
-Einige [[extensions|Erweiterungen]] haben zusätzliche Anforderungen,​ z.B. können manche Plugins nur unter PHP 5 ausgeführt werden. Dies sollte in der Dokumentation der entsprechenden Erweiterung erwähnt sein. 
 
Sie befinden sich hier: start » de » system_requirements
Falls nicht anders bezeichnet, ist der Inhalt dieses Wikis unter der folgenden Lizenz veröffentlicht: GNU Free Documentation License 1.3
Valid XHTML 1.0 Valid CSS Driven by DokuWiki